• Content maintainer and forum moderator nedded for this forum, forum team will pay for that. Please email@ forum@protiva.org

Mikrotik Dual Wan Script [Working]

m1s3rys1gn4l

Administrator
Staff member
#1
Here is Mikrotik Dual wan script, change those ip using ur brain :D



Code:
/ip address
add address=10.10.10.1/24 interface=LAN
add address=192.168.77.6/24 interface=WAN1
add address=192.168.99.6/24 interface=WAN2

/
/
/
/

/ip firewall mangle
add chain=input in-interface=WAN1 action=mark-connection new-connection-mark=WAN1_conn
add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=WAN2_conn

add chain=output connection-mark=WAN1_conn action=mark-routing new-routing-mark=to_WAN1
add chain=output connection-mark=WAN2_conn action=mark-routing new-routing-mark=to_WAN2

add chain=prerouting dst-address=255.255.255.0 action=accept in-interface=LAN
add chain=prerouting dst-address=255.255.255.0 action=accept in-interface=LAN

add chain=prerouting dst-address-type=!local in-interface=LAN per-connection-classifier=both-addresses¬-and-ports:2/0 action=mark-connection new-connection-mark=WAN1_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=LAN per-connection-classifier=both-addresses¬-and-ports:2/1 action=mark-connection new-connection-mark=WAN2_conn passthrough=yes

add chain=prerouting connection-mark=WAN1_conn in-interface=LAN action=mark-routing new-routing-mark=to_WAN1
add chain=prerouting connection-mark=WAN2_conn in-interface=LAN action=mark-routing new-routing-mark=to_WAN2

/
/
/
/ip route
add dst-address=0.0.0.0/0 gateway=192.168.77.1 routing-mark=to_WAN1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.99.1 routing-mark=to_WAN2 check-gateway=ping

add dst-address=0.0.0.0/0 gateway=192.168.77.1  distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.99.1  distance=2 check-gateway=ping

/
/
/
/ip firewall nat
add chain=srcnat out-interface=WAN1 action=masquerade
add chain=srcnat out-interface=WAN2 action=masquerade

/
/
/
 
Top